Installation 500 error

  • Hello,

    I am having some issues installing Perch at the moment.

    I recently migrated all my sites to a new server using the WHM/Cpanel transfer tool.

    I upgraded all sites to php 7.2 and perch runs fine on all these sites.

    I am trying a new install for a development domain which I started from scratch on the new server and the install process works fine up until the user creation which fails when I try to complete and throws me a:

    This page isn’t working is currently unable to handle this request.

    HTTP ERROR 500

    I have looked into everything I could find int FAQ, removing all redirects, ssl and others, clearing the .htaccess , setting a different php version. no luck

    Any idea where I should look?

    I did a manual version of the config.php and it did lead me to the login page, obviously the login fails as the login credentials never made it to the DB.

    Could this be related to a DB issue?

    Any pointers welcome :)

  • PHP Log:

    1. [27-Feb-2019 11:50:31 UTC] PHP Fatal error: Uncaught Error: Call to undefined function iconv() in /home/mysite/public_html/admin/core/lib/PerchUtil.class.php:796
    2. Stack trace:
    3. #0 /home/mysite/public_html/admin/setup/PerchSetup_Installation.class.php(230): PerchUtil::urlify('www-mysite...')
    4. #1 /home/mysite/public_html/admin/setup/PerchSetup_Installation.class.php(111): PerchSetup_Installation->host_filename('www-mysite...')
    5. #2 /home/mysite/public_html/admin/setup/account/index.php(70): PerchSetup_Installation->write_config_file(Array)
    6. #3 {main} thrown in /home/mysite/public_html/admin/core/lib/PerchUtil.class.php on line 796
  • I have now proceeded to just delete the whole account on the new sever, installed perch on the same site on the old server, worked fine. then I copied the old site back onto the new server and all works, but when I tried to change the logo in the perch interface the same error comes up again.

    I deduce it has to do with php permissions but I do not know which one or where to amend this.

    Still any pointers welcome

    PHP Log:

  • drewm

    Approved the thread.
  • Hi Drew,

    That was it, problem solved!

    Provisioned the EasyApache4 Package with the php72-php-intl checked.

    Logo upload succeeded. I haven't run a fresh install but pretty sure that's fine now too since both issues triggered the same error.

    Thank you.