Contact form email responses and GoDaddy

  • Avoid special characters in the Contact Form Form Options email subject lines when at Editing form options. At least, this advice applies to hosting on GoDaddy.

    Not all contact form response emails were arriving as expected. Debug seemed to look alright.

    My config file is straightforward. I did not use the email configuration in the docs. There was a point at which the emails had arrived, but something had changed—not files— so...a mystery.

    At GoDaddy, cPanel > email > email routing > select a domain > configure email was set to Remote Mail Exchanger for both the domain and subdomain.

    The problem turned out to be a special character in the autoresponse email subject line. I had written "Thank you for contacting us!" The exclamation point caused the failure on the GoDaddy end.

    I had used an HTML document for the response, but the same problem occurred when choosing "Plain Text."

    The change from the successful setting had been adding an exclamation point.

    Hope this helps! My son-in-law had advised that I avoid GoDaddy for hosting, but the client was set on it.

  • drewm

    Approved the thread.
  • John, I've had similar weird one off issues with GoDaddy. I will say that the engineers behind the scenes have really done a nice job with the performance of their servers over the last few years. 3 years ago I would have avoided GoDaddy like the plague but they have drastically improved in regards to my speed testing. I would say for shared hosting environments they are on probably better than most of the other guys on the market. This is of course U.S. based testing so I'm not speaking to anything else.