PHP 7.3 Install Error

  • Hi, When I try a clean install of Perch 3.1.5 on PHP 7.3 I get the following:


    Warning: Zend OPcache API is restricted by "restrict_api" configuration directive in /srv/users/folder/apps/app-name/public/customperchname/core/lib/PerchUtil.class.php on line 1427

    Warning: Cannot modify header information - headers already sent by (output started at /srv/users/folder/apps/app-name/public/customperchname/core/lib/PerchUtil.class.php:1427) in /srv/users/folder/apps/app-name/public/customperchname/core/lib/PerchUtil.class.php on line 233


    Downgrading the server to PHP 7.1 solves the issue and installs with no errors.


    I don't believe I am doing anything wrong / I believe this is a bug.


    Note: Items in red abstracted for privacy.

  • drewm

    Approved the thread.
  • Hi Drew,


    I've asked and it was made a default for increased security.


    It provides increased security and limits PHP opcache API calls to the path specified in that directive.