Posts by Pete

    This does seem to be my issue as I've had this with other Perch projects. What is your setup to manage multiple websites?


    I use MAMP so it goes MAMP/htdocs/projectname/


    Perch then sits in the individual project..


    How/where is the local root defined to exclude the project folder?

    I appreciate your efforts Clive, thank you.


    I'm attaching the live server screenshot of the location showing /index.php. This is what you're referring to?


    The local version shows projectname/index.php/ - when I change that to just index.php, it creates the new page with new duplicate regions again. It also deletes in the index.php page. When I resave the index.php file, new page, new region is created and the old location is back.


    I'm not sure if I'm still misunderstanding you (apologies if so) or if my local server configuration is wrong in some way. It's not my strong point ||

    ah ok thank you Clive. Would this be determined in the config.php file loginpath?


    Problem I seem to have is that on local it needs to be projectname/perch/ and live it needs to be just /perch/ and I'm not sure why. I'm assuming this will happen on every page...

    This is a better example attached. I added a new region called "Exhibition Section" and added the content locally.


    - I changed the page name locally to "Home page" to match the live server name in case that was the problem (why is there a difference, where is this set?)

    - Exported the .sql file to live server.

    - When I refreshed the home page, the content is gone and I need to set up the regions again.


    Thanks in advance...

    Hi all,


    When I upload changes I’ve made in Perch from local to live, I keep having to set up the region again and re-add the content.


    For example, I set up a “welcome” region so the customer can edit their welcome text on the home page. I go into Perch, I see the region load, I declare it as a “text block” template and then I can enter the content. It all shows correctly on the page.


    If I then add a new editable region, say “news” locally, then upload, the new region correctly shows, but the existing “welcome” also shows up as a new region and I have to keep redoing it. The old region is still in Perch but doesn't show on the web page. I've attached the screenshot which shows both regions. I'm not sure why one says "home" and one says "home page" in this case either.


    I am exporting the .sql file each time so db is up to date. And I am not changing the region names each time so <?php perch:content(‘Welcome’); ?> is unchanged.


    This is obviously at a simple level but it would be good to understand what I’m doing wrong now before I start developing this project deeper and adding more content.


    Does anyone know what I’m doing wrong please? Have I explained it well enough?

    Gareth S


    It's been two weeks since your last response and I've not yet heard anything. I think that means literally nobody is looking into this, right?


    My question is this. Are you going to look into it or not? There is no point saying you will, if you won't. I can't wait forever with this so please just give me an answer so I can move forward with or without Perch.


    Cheers

    Thanks Gareth S


    I look forward to receiving some news. I appreciate there is a lot going on and this is a small issue; but I'm wondering when I might get an update? I fear small issues get pushed to the bottom of the queue and would think this was relatively straight forward to deal with. I can contact the currently license owner directly if that would speed things up?


    Many thanks

    Pete

    I have a client who purchased a V2 license with a developer only to wait in vain for the site to be developed. I've now taken over and have been watching and waiting for news like everyone else.


    My question is, does anyone know if I can transfer the license to my account from the other developer (who didn't get the project live at any point), AND upgrade to V3.2?


    With all the uncertainty with Perch at the moment, it's not easy to recommend they purchase a new license.....so just seeing where we stand.


    I did email Perch directly but they haven't replied...


    Thanks in advance....

    Hi all,


    So I've got the blog all set up. I'm showing my posts on the blog/news page and I'm using perch_blog_custom to show the title, image and excerpt on the home page.


    My question is, is there a way to crop the image on the home page to a different size to that of the main blog post? I need the main blog image to be square (which I have got) and the home page image to be 2:1 ratio.....


    I am using different templates for each. So "post_in_list.html" for the blog page and "homepage_post_in_list.html" for the home page and have set the image to be cropped to the sizes I want to have. But I'm getting all squared images...


    Thanks!