Member Image Not Saving

  • I have a fresh install of Runway 3.1.4 with Members 1.6.4. Here's my member.html:

    1. <perch:members order="1" type="image" id="logo" label="Logo" width="800" bucket="members">
    2. <perch:members order="2" type="text" id="name" label="Name" listing="true" />

    When I upload the image, everything works like it should (asset is uploaded and shows on edit page) until I save, then the image disappears.

    Here's debug when I try to save the image:


  • FYI I also tried adding closing slashes in member.html. No dice. This was a fresh install, I set up Runway, added the Members app and this was the first thing I tried to do. I was attempting to whip together a quick demo for a client but now I've been waiting on this for 3 days. I've added images to members before and never had problems, so I wonder if this may be an incompatibility between the members app and latest version of Runway? A resolution would be very much appreciated!

  • Drew, just to be sure I installed another fresh copy of Runway w/ Members app, loaded that member.html file, tried to save an image and got the same thing. Do you think this could be some kind of incompatibility between Runway and Members? What do you need from me to get this resolved?

  • After scouring the forums, I've come to realize that this has been an issue with the Members app for years. Basically the image is uploaded and saved, but will not show in the admin area. You can still call it in the frontend using <?php echo perch_member_get('logo')['_default']; ?>…mage-not-showing-in-admin…bers-app-upload-fileimage…images-in-the-members-app