Can't login to Perch nothing on server change but code adjustment so logout to members only would not error out

  • Here are the codes we changed to fix the Logout issue did it cause us to be locked out of Perch CMS?

    We have version 3.1.4 of Perch with Version 1.4 of Members only section. Members only section pages (not coding) are highly customized so we would prefer to keep them as there are if possible, but need the logout page to work correctly

    from logout.php file

  • Is this from another thread? If you are being logged out of Perch - is that your issue?

    I think you will have problems if you start modifying core files. And I don't imagine the Perch developers would support this.

    If you are getting logged out of Perch, I think this would be hosting-related. That's the first thing I would be checking.

    My suggestion, make copy of site and run it locally or on a testing sub-domain. See if you get the same issues.

  • Early on with the log out problem we wrote the forum no help so in desparation we had to find a solution which work up until the browser updates a couple nights ago.

  • Does the members-only section code need to be updated to 1.6? The folder says one thing but the code is really 3.1.4 Is that the problem? I have made many customized templates using the code given in the 1.4 templates and have a secure folder outside the public HTML directory. Is that going to be a problem if I update the 1.4 to 1.6 version? Will that all have to be undone. It has been so long ago that I did that I do not know where the code to make a secure folder outside the public directory is. Would I have to change that to work with 1.6. Where did you have to put that in 1.4

  • I don't fully understand your problem. You were being logged out of Perch and you have modified a core file to stop this happening. Is that correct?

    I don't understand if you are now having a problem with the Members app or Perch 3.1.4?

    Either way, if you have modified Perch core files, it's very difficult to help you here.

    I don't think you will need to amend Members app or its templates if you upgrade to Perch 3.1.7 (the latest version), which I think is what you are asking. However, I'm not sure if I have a clear understanding of the problem you are having.

    My advice is the same as my original post.

    After that, if the problem remains, and/or you cannot resolve problem with web hosting company, well, perhaps you can try a different server on a different host.

  • The error that we saw said a file in the core lib/PerchUtil.class.php line 233 about the header. We commented that out that line only and everything was working until we couldn't login.

  • Ok reset all files to original here are the problems.

    1. When we log out of members only section you get to a blank page. /members/ page which would be the index.php page that you login on. We have a link on that page that take you back to the right place. Page is blank -- no code on the page either Nothing. Logout file is below I is from the original software but does not work. It seems to log you out if you don't test it hundreds of times.





    ?> This is the logout.php

    2. Have finally got a sense of the issues with the login pages for the CMS, if you try to reset the password it tries to get to the reset password page and you get this


    Nothing is being passed so the page is blank.

    Again if you try to login with your credentials you can but when you hit login you get to a blank page with nothing on it. There is something terribly wrong. We have found that two of the adms has expired and do not know how to reset that. But the one that hasn't won't work either. How do you reset the file that puts in expired into the database.

    Really need help with this it is a huge site and would have to be totally redone and gbs of data re-entered. Please some one give us a clue with this.

  • I suggest you set-up the site on testing server on a sub-domain and get a developer to look at the issues including the file structure. The reason I say that is that you appear to be logging in to a URL that contains /pggs2.8.6_update/. I don't know your file structure but it seems unusual to me that you are attempting to login to a URL that appears to be an "update".

    I don't see any reason why the site or data needs to be redone. In the first instance, you need to make sure that you have an install of the site on testing server and start checking things like error logs.

  • The pggs2.8.6_update is the perch file. I just named it that on the original install. The updated core files etc are in that folder.

    It is just the same as if you logge into nameofsite/perch/ That is the file we login to get to the CMS files. It is setup that way on all my sites without any issue. But I will check the error logs to see if that indicates anything.

  • Hi

    Take a copy of the site offline and work locally with debug and errors turned on as Clive suggests. Working on a live site is not ideal. If you can fix your css folder name at the same time that might help even the playing field. All those dots in a url are not really best practice imho.

    Then summarise your problem, post your member page templates (preferably code formatted using the toolbar above) along with your diagnostic settings so the community can help you further. Otherwise I fear you are going to continue banging your head on a brick wall in the echo chamber of official Perch support.

    Kind regards


  • I can't get in to the CMS to do that- that is one of the problems but here is the error log. What does this mean I did finally get the server fixed so the server errors are seen. Perch debug is not working. Nothing showing there.

    [Tue Apr 13 08:30:34.852899 2021] [:error] [pid 1957643:tid 47164318918400] [client] < Content-Length: 71\r, referer: https://www.palamgermangenealo…

    [Tue Apr 13 08:30:34.852934 2021] [:error] [pid 1957643:tid 47164318918400] [client] < Content-Type: text/html; charset=UTF-8\r, referer: https://www.palamgermangenealo…

    [Tue Apr 13 08:30:34.852955 2021] [:error] [pid 1957643:tid 47164318918400] [client] < X-Varnish: 19620594\r, referer: https://www.palamgermangenealo…

    [Tue Apr 13 08:30:34.852966 2021] [:error] [pid 1957643:tid 47164318918400] [client] < Age: 0\r, referer: https://www.palamgermangenealo…

    [Tue Apr 13 08:30:34.852996 2021] [:error] [pid 1957643:tid 47164318918400] [client] < Via: 1.1 varnish (Varnish/5.0)\r, referer: https://www.palamgermangenealo…

    [Tue Apr 13 08:30:34.853012 2021] [:error] [pid 1957643:tid 47164318918400] [client] < X-Cache: MISS\r, referer: https://www.palamgermangenealo…

    [Tue Apr 13 08:30:34.853044 2021] [:error] [pid 1957643:tid 47164318918400] [client] < Accept-Ranges: bytes\r, referer: https://www.palamgermangenealo…

    [Tue Apr 13 08:30:34.853068 2021] [:error] [pid 1957643:tid 47164318918400] [client] < Connection: keep-alive\r, referer: https://www.palamgermangenealo…

    [Tue Apr 13 08:30:34.853074 2021] [:error] [pid 1957643:tid 47164318918400] [client] < \r, referer: https://www.palamgermangenealo…

    [Tue Apr 13 08:30:34.853125 2021] [:error] [pid 1957643:tid 47164318918400] [client] * Connection #0 to host left intact, referer: https://www.palamgermangenealo…

  • So many problems! I can't understand why you can't get into the CMS when you can make changes on to the templates? Can't you get into ftp through the hosting and download the files from there?

    From a glance at the errors above it looks like Varnish is running on your server. That's an eater of caches which might make your logins permanent. Have you tried turning it off in the hosting?

  • I have not done that but will check into that. I did notice in the admin table on the database that the people that are active admins have a column where it says expired. How do you get rid of that? Must mean something bad.

  • FYI the go around for the Login issue for the CMS. We figured out what page we should have been getting to after we are logged in. Then type in the address to the CMS page and viola it is working.

    Still an issue with the logout. The page is not going to the page we want.






    We do not want to get the blank page at /members/ we want to go directly to another website. Actually, the member's index.php page is not blank but we are not getting there. Please help with this -- working on this for a long time. No resolution in sight. we have tried typing in / but that does not take you to the website. /members/ does not take you to the index page in the member's section either. What is wrong with that part of the code. This is the original code.